В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
asvpdsh
asvpdsh
08.07.2020 17:14 •  Информатика

Написать программу в PascalABC, использую в образец с подпрограммой процедурой для исполнителя Чертежник для типа задания р Очень

Показать ответ
Ответ:
Sdkaj
Sdkaj
10.06.2020 19:49

Язык СИ (Откомпилирован и проверен был в Dev-C++)

 

#include <stdio.h>
#include <stdlib.h>
#include <conio.h>

int main()
{
    int a, b, c;
    printf("\n Vvedite 3 chisla :  ");
    scanf("%d" "%d" "%d", &a, &b, &c);
   
    if (a > b && a > c) printf("\n a = %d", a);
    if (b > c && b > a) printf("\n b = %d", b);
    if (c > b && c > a) printf("\n c = %d", c);
    if (a == b && a > c) printf("\n a = %d b = %d", a, b);
    if (a == c && a > b) printf("\n a = %d c = %d", a, c);
    if (b == c && b > c) printf("\n b = %d c = %d", b, c);
    if (a == b && a == c) printf("\n a = %d b = %d c = %d", a, b, c);

 printf("\n\n press klavishy... ");
 getch( );

 return 0;
}

 

Паскаль (Откомпилирован и проверен был в Pascal ABC)

program z1;
uses crt;
var a, b , c: integer;

begin

write('Vvedite 3 chisla:  ');
readln(a, b, c);

if (a > b) and (a > c) then writeln(' a = ', a);
if (b > c) and (b > a) then writeln(' b = ', b);
if (c > a) and (c > b) then writeln(' c = ', c);
if (a = b) and (a > c) then writeln(' a = ', a, ' b = ', b);
if (a = c) and (a > b) then writeln(' a = ', a, ' c = ', c);
if (b = c) and (b > c) then writeln(' b = ', c, ' c = ', c);
if (a = b) and (a = c) then writeln(' a = ', a, ' b = ', b, ' c = ', c);

end.

0,0(0 оценок)
Ответ:
Исма124
Исма124
25.04.2020 18:44

1. Внимательно читаете задачу. Вникаете в смысл. Выясняете, все ли термины  известны и понятны. Детально представляете себе ситуацию задачи или как идет прощесс, описанный в задаче.

2. Записываете данные.

3. Записываете, что нужно найти.

4. Вспоминаете все возможные соотношения и формулы, связывающие параметры, данные в задаче, с тем параметром, который нужно найти.

5. Решаете задание в общем виде - это значит выводите формулу, в которой известны все величины, кроме искогомого. Подставляете известные значения в формулу и вычисляете. Можно делать вычисления и постадийно - это уж как вам удобно.

6. Проверяете размерности. В конечную формулу вместо числовых значений подставляются размерности соответствующих величин. Если конечная размерность не соответствует размерности искомого, значит нужно искать ошибку. Если соответсвует, то это еще не полная гарантия, что ответ правильный.

7. Проверка. Решаем обратную задачу: считаем, что какое-либо из первоначальных данных неизвестно, и на основании найденного ответа вычисляем этот "условно неизвестный параметр". Если результат вычислений совпадает в данными, значит задача решена верно. Если нет - ищите ошибку.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота