В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
rbaimova
rbaimova
19.07.2022 09:05 •  Информатика

Написать программу в паскале: дано натуральное число n. заменить порядок следования цифр числа n на обратный.

Показать ответ
Ответ:
angelina2003po
angelina2003po
05.07.2020 14:15
Var
  n,x:string;
  i:integer;
begin
write('Введите число n: ');
readln(n);
for i:=length(n) downto 1 do x:=x+n[i];
writeln('Обратное число: ',x)
end.

или можно так:

var
  n:string;
begin
write('Введите число n: ');
readln(n);
writeln('Обратное число: ',ReverseString(n) )
end.
0,0(0 оценок)
Ответ:
yliya302
yliya302
05.07.2020 14:15
Var a, N: integer;
begin 
    writeln('Введите число'); 
    readln(N); a:=0; 
    while N>0 do begin 
        a:=a*10+N mod 10;  
        N:=N div 10; 
      end; 
   writeln (a); 
   readln; 
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота