Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
Показать больше
Показать меньше
TruLLa
28.02.2021 01:45 •
Информатика
Написать программу в паскале. дано произвольное целое положительное число k. найти сумму всех чётных цифр этого числа
Показать ответ
Ответ:
Kirillik17091
12.07.2020 01:56
Program folsc;
uses crt;
var s, n:longint;
begin
s:=0;
read (n);
while (n <> 0) do begin
if ((n mod 10) mod 2) =0 then s:=s+n mod 10;
n:=n div 10 end;
writeln (s);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
Katyusha4368
12.07.2021 23:45
Сколько байт информации содержится в 0,25 кбайт ?...
yuniman
10.10.2020 19:42
Запишите числа в виде суммы разрядных слагаемых:...
Aminka26
10.10.2020 19:42
Составьте программу для решения следующей . мальчик взял деньги на мелкие расходы в размере x р. из них y он истратил на сладости. вычислите сколько денег у него осталось?...
egorikysik
10.10.2020 19:42
Усовершенствуйте программу тablmul таким образом, чтобы в результате выводилась оценка, поставленная ученику. критерии для выставления оценок придумайте сами. ! буду используйте:...
Ололошка580
23.02.2023 02:03
РЕШИТЬ В PYTHON Цена товара обозначена в рублях с точностью до копеек, то есть действительным числом с двумя цифрами после десятичной точки. Запишите в две целочисленные переменные...
Аннаlove2017
08.04.2021 10:03
В чем состоит различие между языком разметки гипертекста и языками программирования?...
MARZHIVANKINA
22.06.2021 20:39
План для того, щоб виділити в змісті тексту найважливіше и за-аначити послідовність викладу думок.орієнтовна схема складного плану1. вступ.1. основна частина.2.ii. висновок....
kamallm712oxbgkk
22.06.2021 20:39
my uncle harry s forty years old. he s tall withfair hair and blue eyes. uncle harry s a vet. he1) work/works at the animal hospital instonebridge. uncle harry doesn t 2) wearl...
Whatafaka718
10.08.2022 04:45
Определите метод исследования по рисунку ...
gunelmustafaeva
18.02.2021 23:55
Як збулося пророцтво про загибель трої через паріса? !...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
uses crt;
var s, n:longint;
begin
s:=0;
read (n);
while (n <> 0) do begin
if ((n mod 10) mod 2) =0 then s:=s+n mod 10;
n:=n div 10 end;
writeln (s);
end.