Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
Показать больше
Показать меньше
newaktau
21.08.2022 13:54 •
Информатика
Написать программу в паскале, которая вычисляет среднее арифметическое ненулевых элементов массива м[1..100], элементы которого вычисляются по формуле: м[i]=sin(i)*cos(i) нужно, .
Показать ответ
Ответ:
Айринчик
22.09.2020 16:10
1. Вот так сейчас решают подобные задачи:
// PascalABC.NET 3.1, сборка 1174 от 22.02.2016
begin
Writeln(Range(1,100).Select(i->sin(i)*cos(i)).Where(x->x<>0).Average)
end.
Тестовое решение:
-0.00136006072493969
2. А вот так учат писать это же школьные учителя:
// PascalABC.NET 3.1, сборка 1174 от 22.02.2016
var
m:array[1..100] of real;
i,k:integer;
s:real;
begin
s:=0;
k:=0;
for i:=1 to 100 do begin
m[i]:=sin(i)*cos(i);
if m[i]<>0 then begin
s:=s+m[i];
k:=k+1
end
end;
Writeln(s/k)
end.
Тестовое решение:
-0.00136006072493969
0,0
(0 оценок)
Популярные вопросы: Информатика
kskvortsovak07
27.11.2020 14:35
Сколько надо бит, чтобы можно было составить 32 разных кодов?...
Polllina2209
31.05.2020 02:24
8. Какое число получится в результате выполнения программы: print (20-2)+14/2) 1525352010...
Olegggg04
14.06.2022 16:18
4й вопрос, код паскаль...
spacgumenmari1
08.06.2022 10:04
Опишите последовательность создания трехмерной модели стола впрограмме SketchUp...
ldlopirdlidnsp01mup
20.04.2022 01:39
Выберите строку, в которой перечислены расширения графических файлов. *.avi, *.mp4 *.gif, *.jpg, *.png, *.tif *.txt, *.doc, *.rtf *.exe, *.com...
natalyakulesch
11.03.2022 20:09
Как называются графические объекты, используемые в векторной графике? символы примитивы биты пиксели...
Рюка
31.01.2020 01:13
Составить синквейн на тему вверх дном...
npapriko
31.01.2020 01:13
Составить пример линейного алгоритма из 10 последовательных шагов на любую тему...
геля217
31.01.2020 01:13
Який набір хромосом має зигота...
rutituti
28.04.2023 18:16
До какого числа должно измениться значение счетчика i в фрагменте программы, чтобы C стало равным 14? C:=2; for i:=3 to … do C:=C+i;...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
// PascalABC.NET 3.1, сборка 1174 от 22.02.2016
begin
Writeln(Range(1,100).Select(i->sin(i)*cos(i)).Where(x->x<>0).Average)
end.
Тестовое решение:
-0.00136006072493969
2. А вот так учат писать это же школьные учителя:
// PascalABC.NET 3.1, сборка 1174 от 22.02.2016
var
m:array[1..100] of real;
i,k:integer;
s:real;
begin
s:=0;
k:=0;
for i:=1 to 100 do begin
m[i]:=sin(i)*cos(i);
if m[i]<>0 then begin
s:=s+m[i];
k:=k+1
end
end;
Writeln(s/k)
end.
Тестовое решение:
-0.00136006072493969