В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
hekaterina0606
hekaterina0606
27.06.2022 21:30 •  Информатика

Написать программу в питоне
Напишите программу для решения задачи согласно условию


Написать программу в питоне Напишите программу для решения задачи согласно условию

Показать ответ
Ответ:
диана2458
диана2458
16.03.2020 16:34

Объяснение:

A

class Parrot:

   def __init__(self):

       self.phrase = 'Привет, друзья!'

   def say(self):

       print(self.phrase)

       

p = Parrot()

p.say()

B

class Parrot:

   def __init__(self, phrase):

       self.phrase = phrase    

   def say(self):

       print(self.phrase)

       

p1 = Parrot( "Гав!" )

p2 = Parrot( "Мяу!" )

p1.say()

p2.say()

С

class Parrot:

   def __init__(self, phrase):

       self.phrase = phrase    

   def say(self):

       print(self.phrase)

   def newText(self, phrase):

       self.phrase = phrase

       

p = Parrot( "Гав!" )

p.say()

p.newText( "Мяу!" )

p.say()

D

class Parrot:

   def __init__(self, phrase):

       self.phrase = phrase    

   def say(self, count=1):

       print(self.phrase*count)

   def newText(self, phrase):

       self.phrase = phrase

       

p = Parrot( "Гав!" )

p.say()

p.newText( "Мяу!" )

p.say( 3 )

0,0(0 оценок)
Ответ:
viktoriav84
viktoriav84
07.01.2020 04:55

представления целого числа со знаком называется "дополнительный код".

Алгоритм представления положительного числа:

1. Перевести число в двоичную систему счисления

2. Записать число в прямом коде в 16-ти двоичных разрядах

1. 372_{10} = 1 0111 0100_2

2. 0000 0001 0111 0100_2 (дополняем незначащими нулями до 15-ти разрядов и  в старшем разряде ставим 0 в качестве знака положительного числа)

Представление числа: 0000 0001 0111 0100_2

Алгоритм представления отрицательного числа:

1. Перевести модуль числа в двоичную систему счисления

2. Записать число в прямом коде в 16-ти двоичных разрядах

3. Найти обратный код (то есть инвертировать прямой код)

4. Найти дополнительный код, прибавив единицу к обратному коду

1. 372_{10} = 1 0111 0100_2

2. 0000 0001 0111 0100_2 (обычно дополняют незначащими нулями до 15-ти разрядов и в старшем разряде ставят 1 в качестве знака "-", но также допускается не выставлять значение 1 в знаковом разряде, а на следующем шаге проинвертировать все его разряды, не обращая внимания, знаковый ли это разряд или информационный. Я выбрал второй вариант)

3. 1111 1110 1000 1011_2 (заменяем в прямом коде нули на единицы и наоборот)

4. 1111 1110 1000 1011_2 + 1_2 = 1111 1110 1000 1100_2

Представление числа: 1111 1110 1000 1100_2

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота