В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
hotnikita412
hotnikita412
25.03.2021 14:32 •  Информатика

Написать программу в python 3.0 суточный рацион коровы составляет a кг сена, b кг силоса и c кг комбикорма. в хозяйстве, содержащем стадо из k голов, осталось x центнеров сена, y тонн силоса и z мешков комбикорма по 50 кг. сколько еще дней хозяйство сможет кормить коров по полному рациону?

Показать ответ
Ответ:
AliceandCat
AliceandCat
08.10.2020 20:21
Запас сена составляет sx=50x кг, запас силоса sy=50y кг, запас комбикорма sz=50z кг.
За сутки k коров съедят dx=ka кг сена, dy=kb кг силоса и dz=kc кг комбикорма, после чего запасы уменьшаются:
sx=sx-dx, sy=sy-dy, sz=sz-dz. Этот процесс повторяется и прекращается, если выполняется хотя бы одно из условий:
sx<dx, sy<dy, sz<dz. Количество таких повторений будет ответом на задачу.

sx = 50*int(input("Мешков сена: "))
sy = 50*int(input("Мешков силоса: "))
sz = 50*int(input("Мешков комбикорма: "))
k = int(input("Количество голов в хозяйстве: "))
dx = k*int(input("Дневной рацион коровы (сено), кг: "))
dy = k*int(input("Дневной рацион коровы (силос), кг: "))
dz = k*int(input("Дневной рацион коровы (комбикорм), кг: "))
d=0
while sx>=dx and sy>=dy and sz>=dz:
    d+=1
    sx-=dx
    sy-=dy
    sz-=dz
print("Коров можно кормить еще "+str(d)+" дней (дня)")

Написать программу в python 3.0 суточный рацион коровы составляет a кг сена, b кг силоса и c кг комб
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота