В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
7gklass2017
7gklass2017
06.12.2020 09:28 •  Информатика

Написать программу вычесления функции
S=3/6+4/6++15/6​

Показать ответ
Ответ:
sveronika00
sveronika00
26.10.2021 22:31

Код:

#include <fstream>#include <vector>#include <numeric>int main() {    std::ifstream cin("input.txt");    std::ofstream cout("output.txt");    int N, K;    cin >> N >> K;    std::vector<int> buffer(N);    for (int i = 0; i < K; ++i) {        for (int j = 0; j < N; ++j) {            cin >> buffer[j];        }        // Зануляем найденные min и max        *(std::min_element(buffer.begin(), buffer.end())) = 0;        *(std::max_element(buffer.begin(), buffer.end())) = 0;        // Суммируем        cout << std::accumulate(buffer.begin(), buffer.end(), 0) << "\n";    }    return 0;}
0,0(0 оценок)
Ответ:
ЕvilСookie
ЕvilСookie
22.12.2022 02:10
1.
var
  s: string;
  i, count: integer;
begin
  writeln('Vvedite stroky: ');
  readln(s);
  for i := 1 to length(s) - 2 do
    if copy(s, i, 3) = 'abc' then
      count := count + 1;
  writeln('Kol-vo: ', count);
end.
2.
var
  s1, s2: string;
  i, len1, len2: integer;
begin
  writeln('Vvedite stroky 1: ');
  readln(s1);
  writeln('Vvedite stroky 2: ');
  readln(s2);
  len1 := length(s1);
  len2 := length(s2);
  if len1 > len2 then writeln('1 stroka dlinnee')
  else if len1 < len2 then writeln('2 stroka dlinnee')
  else writeln('dlini strok ravnie')
end.
3.
var
  s1, s2, s3: string;
begin
  writeln('Vvedite stroky 1: ');
  readln(s1);
  writeln('Vvedite stroky 2: ');
  readln(s2);
  s3 := s1[1] + s1[2] + s2[1] + s2[2];
  writeln('Novaja stroka: ', s3);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота