Написать программу вывода матрицы в виде таблицы с разделением столбцов. (например, использовать символы «-» и «|»). внимание! программа написана, но надо переделать, чтобы она была с процедурами var i,j,n,m,k,t: integer; a: array[1..50,1..50] of integer; begin write('введите количество строк: '); readln(n); write('введите количество столбцов: '); readln(m); writeln('матрица: '); randomize; k: =m; for i: =1 to m do write(''); writeln; for i: =1 to n do begin for j: =1 to m do begin a[i,j]: =random(101)-50; write(a[i,j]: 6,' | '); end; writeln; for t: =1 to k do write(''); writeln; end; end.
var s:string; mas:array ['a'..'z'] of longint;{индексы элементов соответствуют латинице} c:char; i:longint; begin read(s); for c:='a' to 'z' do{заполнение нулями элементов массива, для запоминания количества элементов в латинице} mas[c]:=0; for i:=1 to ord(s[0]) do{пробегаем по всей строке ord(s[0]) это количесвто элементов в строке (только паскаль)} mas[s[i]]:=mas[s[i]]+1; for c:='a' to 'z' do{пробегаем по массиву значений и выводим только неповторяющиеся} if(mas[c]=1) then writeln(c); end.
2.Мама обрадовала Петю: он совсем не ожидал получить компьютер на день рождения.
3. Учительница сказала, что сегодня мы будем работать на компьютере.
4. Паскаль- самый сложный язык в программировании на компьютере.
5. Вова обожал играть в видеоигры на компьютере.
6. "Ребята, сегодня наш класс пойдёт смотреть в технический музей на первые компьютеры"- сказала учительница.
7. Бабушка удивилась, что Катенька так быстро печатает на компьютере.
8. Настя была опечалена: из-за сломанного usb-порта компьютер не воспринимал съемный носитель.
9. Первые компьютеры были очень большими.
10. Милана очень хотела новый компьютер, но папа посчитал нужным подарить ей книги.