Написать программу: Запустите волну по линейке светодиодов так, чтобы одновременно только 4 светодиода. То есть, как только загорается 4-ый, то 0-ой гаснет, когда загорается 5-ый – гаснет 1-ый и так далее.
1) База данных — это такая совокупность данных, которая организована в соответствии с определёнными правилами и имеющая определённую структуру. Она редактируется при системы управления базами данных (СУБД).
По типу хранимой информации БД делятся на:
-документальные,
-фактографические и
-лексикографические
По характеру организации хранения данных и обращения к ним различают:
-локальные (персональные),
-общие (интегрированные, централизованные) и
-распределенные базы данных
По характеру организации данных БД могут быть разделены на:
-неструктурированные,
-частично структурированные и
-структурированные
По типу используемой модели делятся на:
-иерархические,
-сетевые,
-реляционные,
-смешанные и
мультимодальные
Основные функции СУБД -- управление данными во внешней памяти (на дисках); управление данными в оперативной памяти с использованием дискового кэша; журнализация изменений, резервное копирование и восстановление базы данных после сбоев; поддержка языков БД (язык определения данных, язык манипулирования данными).
2) Реляционная алгебра - это язык операций, выполняемых над отношениями - таблицами реляционной базы данных. Операции реляционной алгебры позволяют на основе одного или нескольких отношений создавать другое отношение без изменения самих исходных отношений. Полученное другое отношение обычно не записывается в базу данных, а существует в результате выполнения SQL-запроса - массиве, создаваемом функциями для работы с базами данных в языках программирования. Для каждой операции реляционной алгебры будет дана её реализация в виде запросов на языке SQL.
таблица PRODUCTS
ID | NAME | COMPANY |PRICE
–
123 | Печеньки | ООО ”Темная сторона” | 190
156 | Чай | ООО ”Темная сторона” |60
235 | Ананасы | ОАО ”Фрукты” |100
623 | Томаты | ООО ”Овощи” |130
Таблица состоит из 4х строк, строка в таблице является кортежем в реляционной теории. Множество упорядоченных кортежей называется отношением.
Перед тем как дать определение отношения, введем еще один термин — домен. Домены применительно к таблице это столбцы.
Для ясности, теперь введем строгое определение отношения.
Пусть даны N множеств D1,D2, …. Dn (домены), отношением R над этими множествами называется множество упорядоченных N-кортежей вида <d1,d1,...dn>, где d1 принадлежит D1 и тд. Множества D1,D2,..Dn называются доменами отношения R.
Каждый элемент кортежа представляет собой значение одного из атрибутов, соответствующего одному из доменов.
Решение ниже. Программа на языке с++.
Объяснение:
#include <stdio.h>
#include <iostream>
#include <locale.h>
using namespace std;
int main()
{
setlocale(LC_ALL, "Russian");
int x, i;
cout << "Введите размерность массива: ";
cin >> x;
int* Arr = new int[x];
cout << "Введите " << x << " элементов массива через пробел: " << endl;
for (i = 0; i < x; i++)
{
cin >> Arr[i];
}
cout << endl << "ответ: ";
for (i = 0; i < x; i++)
{
if (Arr[i] % 2 == 0)
{
cout << Arr[i] << " ";
}
}
for (i = 0; i < x; i++)
{
if (Arr[i] % 2 != 0)
{
cout << Arr[i] << " ";
}
}
return 0;
}
1) База данных — это такая совокупность данных, которая организована в соответствии с определёнными правилами и имеющая определённую структуру. Она редактируется при системы управления базами данных (СУБД).
По типу хранимой информации БД делятся на:
-документальные,
-фактографические и
-лексикографические
По характеру организации хранения данных и обращения к ним различают:
-локальные (персональные),
-общие (интегрированные, централизованные) и
-распределенные базы данных
По характеру организации данных БД могут быть разделены на:
-неструктурированные,
-частично структурированные и
-структурированные
По типу используемой модели делятся на:
-иерархические,
-сетевые,
-реляционные,
-смешанные и
мультимодальные
Основные функции СУБД -- управление данными во внешней памяти (на дисках); управление данными в оперативной памяти с использованием дискового кэша; журнализация изменений, резервное копирование и восстановление базы данных после сбоев; поддержка языков БД (язык определения данных, язык манипулирования данными).
2) Реляционная алгебра - это язык операций, выполняемых над отношениями - таблицами реляционной базы данных. Операции реляционной алгебры позволяют на основе одного или нескольких отношений создавать другое отношение без изменения самих исходных отношений. Полученное другое отношение обычно не записывается в базу данных, а существует в результате выполнения SQL-запроса - массиве, создаваемом функциями для работы с базами данных в языках программирования. Для каждой операции реляционной алгебры будет дана её реализация в виде запросов на языке SQL.
таблица PRODUCTS
ID | NAME | COMPANY |PRICE
–
123 | Печеньки | ООО ”Темная сторона” | 190
156 | Чай | ООО ”Темная сторона” |60
235 | Ананасы | ОАО ”Фрукты” |100
623 | Томаты | ООО ”Овощи” |130
Таблица состоит из 4х строк, строка в таблице является кортежем в реляционной теории. Множество упорядоченных кортежей называется отношением.
Перед тем как дать определение отношения, введем еще один термин — домен. Домены применительно к таблице это столбцы.
Для ясности, теперь введем строгое определение отношения.
Пусть даны N множеств D1,D2, …. Dn (домены), отношением R над этими множествами называется множество упорядоченных N-кортежей вида <d1,d1,...dn>, где d1 принадлежит D1 и тд. Множества D1,D2,..Dn называются доменами отношения R.
Каждый элемент кортежа представляет собой значение одного из атрибутов, соответствующего одному из доменов.
Объяснение:
Пришломь потрудиться, но думаю хорошо обьяснил
Я смог