В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
demondru
demondru
02.01.2020 05:37 •  Информатика

Написать в pascal abc. задано трехзначное восьмеричное (двоичное) число. составить программу для перевода этого числа в десятичную систему счисления.

Показать ответ
Ответ:
KLIN50
KLIN50
30.08.2020 08:11

перо Сместиться в точку (1,7) Сместиться в точку (1,5) Поднять перо Сместиться на вектор (0,-2) Опустить перо Сместиться на вектор (2,0) Сместиться в точку (3,5) Сместиться на вектор (-2,0) Поднять перо Сместиться в точку (4,5) Опустить перо Сместиться на вектор (2,0) Поднять перо Сместиться в точку (5,6) Опустить перо Сместиться в точку (5,4) Поднять перо Сместиться в точку (7,3) Опустить перо Сместиться на вектор (2,0) Сместиться на вектор (0,4) Сместиться в точку (7,7) Сместиться в точку (7,5) Сместиться в точку (9,5) Поднять перо В ответе укажите только число, без пробелов и каких-либо знаков препинания, например 100 ответ:

Объяснение:

0,0(0 оценок)
Ответ:
VasyPupok228
VasyPupok228
10.05.2022 07:36

Объяснение:

const

 n = 10;

 ar:array[1..n] of integer = (-2, -1, 2, 3, 4, 5, -5, -6, 2, 5);

var

 i:integer;

 is_first_pol:boolean;

 raz_pol:integer;

begin

 

 raz_pol:=0;

 is_first_pol:=true; // флаг того, что найденное положительное число - первое

 

 for i:=1 to n do begin

   

   if (ar[i] > 0) then

     

     if (is_first_pol) then begin

       // если найденное полодительное число - первое, то

       raz_pol:=ar[i]; // в нашу разницу заносим это число

       is_first_pol:=false; // меняем флаг

     end

     else raz_pol:=raz_pol - ar[i]; // иначе вычисляем разницу

 

 end;

 

 writeln(raz_pol);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота