В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
varzhyv
varzhyv
21.01.2023 06:56 •  Информатика

напишите на каком языке программировали: E. Числа Армстронга
Ограничение времени 1 секунда
Ограничение памяти 64Mb
Ввод стандартный ввод или input.txt
Вывод стандартный вывод или output.txt
Натуральное десятичное N-значное число называется числом Армстронга, если сумма его цифр, возведенных в степень N, равна самому числу.

Примеры:

153 = 13 + 53 + 33

1634 = 14 + 64 + 34 + 44

Напишите программу, которая находит все числа Армстронга на отрезке [a , b] .

Формат ввода
Входная строка содержит два натуральных числа – значения a и b , разделённых пробелами. Гарантируется, что 1 ≤ a ≤ b ≤ 106 .

Формат вывода
Программа должна вывести в одну строчку все числа Армстронга на отрезке [a , b] , разделив их пробелами. Если таких чисел нет, программа должна вывести число -1

Пример 1
Ввод Вывод
100 400
153 370 371
Пример 2
Ввод Вывод
500 600
-1

Показать ответ
Ответ:
Andreyко
Andreyко
22.04.2022 17:59
1.
0,5 Кбайт = 0,5*1024 байт = 512*8 бит
512*8/128 = 32

2.
Память для одного символа = log(2)64=6 бит
Объем текста = 10*32*64*6 бит = 10*32*64*6/8 байт =
10*4*64*6/1024 Кбайт = 15 Кбайт

3.
3 Кбайт = 3*1024 байт = 3*1024*8 бит
Память для одного символа = 3*1024*8/6144 = 4 бита
Количество символов в алфавите = 2^4 = 16

4.
Память для одного символа = log(2)128=7 бит
Объем сообщения = 10*7 = 70 бит

8.
a) 3 Кбайт=3*1024 Байт = 3072 бАЙТ
b) 2 Мбайт=2*1024 Кбайт = 2*1024*1024 байт = 2*1024*1024*8 бит = 16777216 бит
c) 4,5 Гигабайт=4,5*1024 Мбайт = 4,5*1024*1024 Кбайт = 4718592 Кбайт
0,0(0 оценок)
Ответ:
Vspichka
Vspichka
21.05.2022 17:50
Задача №1
var a:array[1..4, 1..5] of integer; 
i,j,k:integer; 
begin 
writeln('Заполните матрицу'); 
for i:=1 to 4 do 
for j:=1 to 5 do begin 
read(a[i,j]); 
if (a[i,j] mod 3=0) and (a[i,j]>20) then k:=k+a[i,j]; 
end; 
writeln('Сумма элементов кратных 3-м и > 20 = ',k); 
end.

Задача №2
var a:array[1..5, 1..5] of integer; 
i,j,k:integer; 
begin 
writeln('Заполните матрицу'); 
for i:=1 to 5 do 
for j:=1 to 5 do begin 
read(a[i,j]); 
if i=j then k:=k+a[i,j]; 
end; 
writeln('Сумма элементов главной диагонали = ',k); 
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота