В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География

Напишите программу чертежник с именем маша не файл а просто тип
тспользовать чертежник
алг_имя

Показать ответ
Ответ:
НЕЗНАЙКА123987
НЕЗНАЙКА123987
25.01.2020 05:04
Var b,c:boolean;
a:integer;
begin
readln(a);
writeln(not odd(a));
if a mod 10 = 7 then b:=true;
writeln(b);
writeln(not odd(a mod 10));
end.

var r,a:integer;
begin
read(r,a);
if a*a>pi*r*r then writeln('Square')
else if a*a<pi*r*r then writeln('Circle')
else writeln('Equal');
end.

var m1,m2,v1,v2:integer;
begin
read(m1,v1,m2,v2);
if m1/v1>m2/v2 then writeln('p1>p2')
else if m1/m2<m2/v2 then writeln('p1<p2')
else writeln('p1=p2');
end.

var a,b:real;
begin
read(a,b);
b*=0.45;
if a>b then writeln(b)
else if a<b then writeln(a)
else writeln('Equal');
end.
0,0(0 оценок)
Ответ:
S - Заданная символьная строка
s2 - Заданное слово
Идея проста: мы проходим по заданной строке и копируем подстроку, начиная с символа i, с количеством символов, равным количеством символов заданного слова. Например:
Символьная строка:
34строка3254строка
Заданное слово:
строка
Мы просто берём и проходим циклом
34строка3254строка
34строка3254строка
34строка3254строка
...
и т.д. до самого конца. Если рассматриваемая нами подстрока равна заданному слову, то мы увеличиваем счётчик k на 1, после завершения цикла мы просто возвращаем значение нашего счётчика - количество вхождений заданного слова в строку.
P.S. Мы идём циклом не от 1 до length(s), а от 1 + l1 - l2. К примеру в нашей строке
нет смысла рассматривать подстроку, начиная отсюда
34строка3254строка
т.к. символов в ней явно меньше чем в самом заданном слове, следовательно, дальше оно нам уже не попадётся:)
Исходный код в приложении.

Напишите функцию, которая определяет, сколько раз входит в символьную строку заданное слово.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота