НАПИШИТЕ ПРОГРАММУ Дан порядковый номер месяца (1,2,…, 12). Напишите программу, которая выводит на экран количество дней в этом месяце. Принять, что год является невисокосным.
Var a, b, c: integer; begin write('Введите углы a, b, c >> '); readln(a, b, c); if a+b+c = 180 then if (a>0) and (b>0) and (c>0) then begin if (a=b) and (b=c) then writeln('Равносторонний '); if ((a=b) and (a<>c)) or ((b=c) and (b<>a)) or ((a=c) and (c<>b)) then writeln('Равнобедренный '); if (a<>b) and (b<>c) and (a<>c) then writeln('Разносторонний '); if (a=90) or (b=90) or (c=90) then writeln('Прямоугольный '); if (a>90) or (b>90) or (c>90) then writeln('Тупоугольный '); if (a<=89) and (b<=89) and (c<=89) then writeln('Остроугольный ') end else writeln('Углы должны быть больше 0') else writeln('Сумма углов не равна 180 градусам'); end.
var s:real; flag,d,m:integer; begin s:=10; d:=1; while s<=100 do begin writeln('d: ',d,' s: ',s); {эта строка не обязательна, выводит на экран ежедневный пробег, как бы для контроля} s:=s+s*0.1; d:=d+1; if s<20 then flag:=d; end; writeln('> 20 km :', flag+1,' day'); writeln('>100 km : ',d); end.
begin
write('Введите углы a, b, c >> ');
readln(a, b, c);
if a+b+c = 180 then
if (a>0) and (b>0) and (c>0) then
begin
if (a=b) and (b=c) then writeln('Равносторонний ');
if ((a=b) and (a<>c)) or ((b=c) and (b<>a)) or ((a=c) and (c<>b)) then writeln('Равнобедренный ');
if (a<>b) and (b<>c) and (a<>c) then writeln('Разносторонний ');
if (a=90) or (b=90) or (c=90) then writeln('Прямоугольный ');
if (a>90) or (b>90) or (c>90) then writeln('Тупоугольный ');
if (a<=89) and (b<=89) and (c<=89) then writeln('Остроугольный ')
end
else
writeln('Углы должны быть больше 0')
else
writeln('Сумма углов не равна 180 градусам');
end.
s:real;
flag,d,m:integer;
begin
s:=10; d:=1;
while s<=100 do
begin
writeln('d: ',d,' s: ',s); {эта строка не обязательна, выводит на экран ежедневный пробег, как бы для контроля}
s:=s+s*0.1;
d:=d+1;
if s<20 then
flag:=d;
end;
writeln('> 20 km :', flag+1,' day');
writeln('>100 km : ',d);
end.