В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
адевале1
адевале1
01.01.2021 06:20 •  Информатика

Напишите программу, дано условие и блок-схема. на 1 фото. блок-схема на втором

Показать ответ
Ответ:
Flarissa163
Flarissa163
23.03.2022 21:05

package nikitauser;

import java.util.Scanner;

public class Class {

 public static void main (String[] args) {  

  System.out.println("Куда Вы предпочитаете пойти?");

  try (Scanner scan = new Scanner (System.in)) {

   String a = scan.nextLine().toLowerCase();

   switch (a)

   {

   case "налево":

    System.out.println("Налево пойдёшь - себя потеряешь, коня !");

    break;

   case "направо":

    System.out.println("Направо пойдёшь - коня потеряешь, себя !");

    break;

   case "прямо":

    System.out.println("Прямо пойдёшь - и себя, и коня потеряешь!");

    break;

  default:

    System.out.println("Варианты ответа:\nналево\nнаправо\nпрямо");

    break;

//программа написана на Java 16. Варианты ответов могут быть разными - зависит от сказки ( данная строка - комментарий; можете просто удалить)

   } } } }

0,0(0 оценок)
Ответ:
enindanila24
enindanila24
05.09.2022 00:21

program allliyagilmanova666;

const n = -20;

         m = 0;

         l = 10;

var x, y: double;

     proverka: byte;

begin

proverka := 1;

repeat

 writeln('Введите х:');

 readln(x);

 if (x < -20) then y := 2 * x + 1

  else if ((x >= n) and (x <= m)) then y := 4 * x + 8

   else if ((x > m) and (x < l)) then y := 0

    else y := sqr(x) + 2;

 writeln('При х = ', x : 0 : 2, ' y = ', y : 0 : 2);

 writeln('Если хотите продолжить работу введите 1, в противном случае - 0.');

 readln(proverka);

until (proverka = 0);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота