В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
адильхан9
адильхан9
19.10.2020 05:51 •  Информатика

Напишите программу для решения следующей задачи. На контрольной работе по алгебре ученикам 9 класса было предложено 10 примеров. Неудовлетворительная оценка выставляется, если правильно решено менее половины примеров. Сколько неудовлетворительных оценок было получено учениками? Если хотя бы один из учеников правильно решил все задачи, выведите YES, иначе выведите NO. Программа получает на вход количество учеников в классе N (1 ≤ N ≤ 30), затем для каждого ученика вводится количество правильно решённых примеров.ЯЗЫК С+++

Показать ответ
Ответ:
khavakim
khavakim
15.01.2021 16:33

var a,b,c,d,e:integer;

begin

d:=1;

e:=0;

writeln('введите количество учеников');

readln(a);

for b:=1 to a do begin

writeln('введите количество правильных ответов для ',d,' ученика' );

readln(c);

while (c>10) or (c<0) do begin

writeln('вы ввели неверное число, попробуйте снова');

readln(c);

end;

if c = 10 then e:=e+1;

d:=d+1;

end;

if (e>=1) then writeln('yes ')

else writeln('no');

end.

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота