Напишите программу для решения следующей задачи. Участники парусной регаты стартовали одновременно. На финише фиксировалось время прохождения маршрута каждой яхтой (в часах и минутах). Определите время победителя регаты (в часах и минутах). Известно, что соревнования проходили в течение 12 часов. Программа получает на вход количество яхт, принимавших участие в регате N (1 ≤ N ≤ 100), затем для каждой яхты вводится два числа: часы и минуты, затраченные на прохождение маршрута.
Из курса истории вам известно, какую огромную роль в развитии человечества сыграло возникновение письменности, позволившее зафиксировать устное слово с букв-знаков. Надписи на камне, папирусе, бумаге – не просто сообщения, дошедшие до нас через века. Это документы, позволяющие нам судить о том, как жили люди в ту или иную эпоху, о чём они думали, что их интересовало.
Слово «документ» переводится с латинского как «свидетельство» , «доказательство» . Первоначально оно означало письменное подтверждение событий или фактов. Например, факт рождения каждого человека документально оформляется в виде свидетельства о рождении; по окончании школы вы получаете аттестат – документ, подтверждающий ваше образование, и т. д.
Современное понятие документа значительно шире, чем «бумага,
заверенная печатью и подписью» . Текст является одной из важнейших форм представления информации об окружающей действительности.
Под текстовым документом сегодня понимается информация, представленная на бумажном, электронном или ином материальном носителе в текстовой форме.
Объяснение:
Вот, держи)
Первая задача и вторая в одном проекте.
#include <iostream>
#include <cstdlib>// включает srand() и rand()
#include <ctime> // содержит time
int main(){
float mas[79];
double mult = 1;
srand(time(NULL));// при каждом запуске будут новые случайные числа
for (int i=0; i<79; i++) mas[i] = 0.1*rand();//заполнение массива случайными числами
// Задача 2: произведение этих элементов:
for (int i=0; i<79; i++) mult*=mas[i];
std::cout << "mult = " << mult << std::endl;
system("pause");
return 0;
}
Третья:
#include <iostream>
#define x 3 //определяем максимальный размер массива, сейчас 3
using namespace std;
int main(){ float N[x];
int i;
for (i=0; i<x; i++){ cout << "N[" << i << "]= ";
cin >> N[i];
}
cout << "" << endl;
for (i=0; i<x; i++)
cout << "N[" << i << "] / 2= " << N[i]/2 << endl;
system("pause");
}
Четвертая:
#include <iostream>
#define N 3 //определяем максимальный размер массива, сейчас 3
using namespace std;
int main(){
int mas[N], i, j;
for (i=0; i<N; i++){
cout << "mas[" << i << "]= ";
cin >> mas[i];
}
cout << "" << endl;
for (i=0, j=0; i<N; i++)
if (mas[i] < -3) j++;
cout << "summa mas[i] < -3 = " << j << endl;
system("pause");
}
Пятая:
#include <iostream>
#include <cstdlib>// включает srand() и rand()#include <ctime> // содержит time
#define N 5
int main(){
int mas[N], sum=0;
srand(time(NULL));// при каждом запуске будут новые случайные числа for (int i=0; i<N; i++){
mas[i] = rand();//заполнение массива случайными числами
if (i%2) sum+=mas[i];
}
std::cout<<"sum= " << sum << std::endl;
system("pause");
}