В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
chmy1998
chmy1998
04.01.2023 11:17 •  Информатика

напишите программу, которая бы выполняла перевод(написано должно быть на python

единиц измерения.

в программе должны быть:

1. ввод значения – функция

2. перевод единиц измерения.

3. вывод значения – функция

на свое усмотрение, можете усовершенствовать программу, дополнив разными функциями. выбор единиц измерения

на ваше усмотрение.

пример выполненной работы

например, необходимо перевести единицы измерения

количества информации. воспользуемся таблицей на снимке

допустим, переводим гигабайты в мегабайты. то число,

которое ввел пользователь, следует умножить на 1024, согласно таблице.

в результате будет такая формула:

m = n*1024,

где n – число, которое ввел пользователь,

а m – результат вычислений.

чтобы выполнить обратное преобразование, т. е. из мегабайтов в гигабайты, необходимо делить на 1024. таким

образом, формула имеет вид:

m = n÷1024,

где n – число, которое ввел пользователь,

а m – результат вычислений.

Показать ответ
Ответ:
Рома2043
Рома2043
29.02.2020 07:13
Реализация на VBA Excell
Если есть офис, то можете запустить программу.
Код увидеть Alt+F11

Sub massiv()   
строка = 3 'не обязательно,номер строки для начала вывода на лист   
n = Cells(2, 3) 'не обязательно, вводим количество чисел   
Dim B(10000) As Integer 'резервируем память на 10000 целых чисел   
S = 0 'обнуляем сумму   
For i = 1 To n 'Начало цикла       
   k = Rnd(1) 'Генерируем случайное число в диапазоне (0;1)       
   k = k * 9 + 12 'Смещаем его в диапазон [12;20]       
   k = Int(k) 'обрезаем, оставляя целое       
   B(i) = k 'заполняем массив       
   S = S + k 'считаем сумму       
   Cells(строка, 3) = строка - 2 'не обязательно, вывод номера значеня              
   Cells(строка, 4) = k 'Не обязательно вывод значения       
   строка = строка + 1 'не обязательно, увеличить строку для вывода   
Next i 'Конец цикла   
Cells(строка, 3) = "сумма =" 'не обязательно, выводим надпись   
Cells(строка, 4) = S 'не обязательно, выводим сумму
End Sub
0,0(0 оценок)
Ответ:
MaxSorv
MaxSorv
25.11.2022 21:01
Паскаль АВС.
Программа вывводит дату следующего дня. Чтоб не утяжелять программу, не стал писать проверку правильности введения даты - то есть пользователь должен вводить только правильные цифры :)

Program Upmixer;
var
  day, month, year:integer;
begin
writeln('Введите дату:');
write('День:'); read (day);
write('Месяц:'); read (month);
write('Год:'); read (year);
day:=day+1;
{если было введено 29 февраля високосного года}
if (((year mod 4)=0) and ((year mod 100)<>0) and (month=2) and (day=30)) then
  begin
    day:=1;
    month:=month+1;
  end;
{если было введено 28 февраля невисокосного года}
if (((year mod 4)<>0) and (month=2) and (day=29)) then
  begin
    day:=1;
    month:=month+1;
  end;
{другие дни}
if ((day=31) and ((month=4) or(month=6) or (month=9) or (month=11))) then
  begin
    day:=1;
    month:=month+1;
  end;
if ((day=32) and ((month=1) or(month=3) or (month=5) or (month=7) or (month=8) or (month=10))) then
begin
    day:=1;
    month:=month+1;
end;
{31 декабря}
if ((day=32) and (month=12)) then
begin
    day:=1;
    month:=1;
    year:=year+1;
end;
writeln('Завтра ', day,' ',month,' ',year);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота