Напишите программу, которая по двум данным натуральным числам a и b, не превосходящим 30000, подсчитывает количество натуральных чисел, не кратных 3, на отрезке [a,b]. Программа получает на вход два натуральных числа a и b, при этом гарантируется, что 1≤a≤b≤30000. Проверять входные данные на корректность не нужно.Программа должна вывести одно число: количество натуральных чисел, не кратных 3, на отрезке [a,b].
Входные данные: 7 37
Выходные данные
#include <iostream>
int main()
{
int a,b;
int k=0;
std::cin>>a>>b;
for(int i=a;i<=b;i++)
{
if(i%3!=0)
k++;
}
std::cout<<k;
}
Объяснение:
Язык программирования C++