В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География

Напишите программу, которая по введенному не более, чем четырехзначному числу k будет выдавать сумму его цифр.

Показать ответ
Ответ:
hamidullinelnar
hamidullinelnar
09.10.2020 10:10

var k:integer;

begin

write ('Введите не более, чем четырехзначное число: ');

readln (k);

writeln ('Сумма цифр равна: ',k div 1000 + k div 100 mod 10 + k mod 100 div 10 + k mod 10)

end.

0,0(0 оценок)
Ответ:
joker2284
joker2284
09.10.2020 10:10

Держи на приличном языке:

javascript:var K = parseInt(prompt().substr(0, 4)), сумма = 0; while (K > 0) { сумма += K % 10; K = K / 10 | 0; } alert(сумма);

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота