В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
oksyanna
oksyanna
22.07.2020 22:43 •  Информатика

Напишите программу которая получает с клавиатуры натуральное число которое больше 1 и определяет простое оно или нет. для этого нужно делить число на все натуральные числа начиная с 2 пока не получится деление без остатка repeat и until

Показать ответ
Ответ:
mkagermazov
mkagermazov
09.10.2020 23:55

program simple_num;

var n:integer;


function simple(num:integer):boolean;

var count, i:integer;

   key:boolean;

begin

   count := 0;

   i := 1;

   repeat

       if num mod i = 0 then

           inc(count);

       inc(i);

   until (i > num);

   if count > 2 then

       key := false

   else key := true;

   simple := key;

end;


begin

   writeln('Введите натуральное число больше 1');

   readln(n);

   if n > 1 then

       if simple(n) then

           writeln('Число ',n, ' простое')

       else writeln('Число ',n, ' непростое')

   else writeln('введено число менее 1');

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота