В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
kkarinanexK
kkarinanexK
09.07.2020 10:15 •  Информатика

Напишите программу которая принимает с клавиатуры целое число часов и выводит на экран! ​

Показать ответ
Ответ:
Ruslan3252
Ruslan3252
23.03.2019 11:50

type cl = class

  a: integer;

  constructor create(b: integer);

  procedure setval(b: integer);

  function getval: integer;

  procedure sq;

end;

constructor cl.create(b: integer);

begin

  a : = b;

end;

procedure cl.setval(b: integer);

begin

  a : = b;

end;

function cl.getval: integer;

begin

  getval : = a;

end;

procedure cl.sq;

begin

  if a < 0 then

    writeln('a ^ 2 = ', a * a)

  else

    writeln('error');

end;

var

  obj: cl;

  a : integer;

begin

  write('a = ');

  readln(a);

  obj : = cl.create(a);

  obj.sq;

  readln;

  obj.destroy;

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота