В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География

Напишите программу, которая раскладывает натуральное число N на сомножители A и B , наиболее близкие друг к другу (такие, что модуль разности A - B минимальный). Входные данные
Во входном файле input.txt записано натуральное число N , состоящее не более, чем из 10000 цифр.

Выходные данные
Программа должна вывести два наиболее близких друг к другу сомножителя переданного ей числа в файл output.txt . В первой строчке выводится меньший из сомножителей, во второй – больший.

Примеры
входные данные
868183
выходные данные
911
953

Показать ответ
Ответ:
alesa6002
alesa6002
04.01.2021 23:55
Var a,b,c,D,x1,x2:double; begin Write('Введите коэффициенты квадратного уравнения А В С: '); Read(a,b,c); if a=0 then Writeln('А не может равняться нулю: уравнение не будет квадратным') else begin D:=sqr(b)-4*a*c; if D<0 then Writeln('Нет корней') else if D=0 then Writeln('x=',-b/(2*a)) else begin D:=sqrt(D); x1:=(-b-D)/(2*a); x2:=(-b+D)/(2*a); Writeln('x1=',x1,', x2=',x2) end end end. Тестовое решение: Введите коэффициенты квадратного уравнения А В С: 2 -5 3 x1=1, x2=1.5 ответ у модератора совершенно верен.
0,0(0 оценок)
Ответ:
Metrofanovaa
Metrofanovaa
04.01.2021 23:55
Var
  a,b,c,D,x1,x2:double;
begin
  Write('Введите коэффициенты квадратного уравнения А В С: ');
  Read(a,b,c);
  if a=0 then
    Writeln('А не может равняться нулю: уравнение не будет квадратным')
  else begin
    D:=sqr(b)-4*a*c;
    if D<0 then Writeln('Нет корней')
    else
      if D=0 then Writeln('x=',-b/(2*a))
      else begin
        D:=sqrt(D);
        x1:=(-b-D)/(2*a); x2:=(-b+D)/(2*a);
        Writeln('x1=',x1,', x2=',x2)
      end
  end
end.

Тестовое решение:
Введите коэффициенты квадратного уравнения А В С: 2 -5 3
x1=1, x2=1.5
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота