В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
femalewolf1309
femalewolf1309
10.08.2022 18:35 •  Информатика

Напишите программу, которая считает знаки пунктуации в символьной строке. к знакам пунктуации относятся символы из набора «.,; : ! ? ». формат входных данных программа получает на вход символьную строку (длина строки не больше 100 символов). формат выходных данных программа должна вывести общее количество знаков пунктуации во входной строке. примеры входные данные выходные данные hi, guys! 2

Показать ответ
Ответ:
апааапаппаа
апааапаппаа
07.10.2020 02:40
Var s,p:string; k,i:integer;
begin
readln(s);
p:='.,;:!?';
k:=0;
for i:=1 to length(s) do
 if pos(s[i],p)>0 then k:=k+1;
writeln('k = ',k);
end.

Пример:
Hi, guys!
k = 2
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота