В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
pak2005
pak2005
30.07.2021 03:26 •  Информатика

Напишите программу которая считывает с клавиатуры слово, после чего выводит это же слово четыре раза на одной строке, не разделяя их​

Показать ответ
Ответ:
KsunyaCernecova
KsunyaCernecova
26.12.2022 11:10
Программа поиска элемента в произвольном массиве:
const n=10;
var a:array[1..n+1] of integer;
p,i:integer;
begin
Randomize;
writeln('Исходный массив:');
for i:=1 to n do
 begin
 a[i]:=random(21);
 write(a[i]:4);
 end;
writeln;
write('p = '); readln(p);
a[n+1]:=p;
i:=1;
while a[i]<>p do i:=i+1;
if i<=n
 then writeln('Искомый элемент найден, его номер = ',i)
 else writeln('Искомый элемент не найден');
end.

Пример 1:
Исходный массив:
   7  17  16  13   0   1  19  20  12   5
p = 13
Искомый элемент найден, его номер = 4

Пример 2:
Исходный массив:
  20   4   5  12  14  10  11  16  18  20
p = 15
Искомый элемент не найден
0,0(0 оценок)
Ответ:
Под блокнотом подразумевается стандартный Windows Notepad. Он прост как дважды два, и таким и задумывался. Предназначен для просмотра и возможно редактирования простых текстовых файлов(не документов, форматирование не изменяется), например .txt, .xml, .html и тд
Им можно открыть и посмотреть текстовое представление любого файла, хотя большие файлы он не откроет (зависнет или упадет) и может иметь проблемы с кодировками.
Имеет простейшие функции типа поиск, замена, переход. А так же открыть и сохранить файл.

Если часто приходится иметь дело с текстовыми файлами предназначеными в первую очередь для чтенье компьютером типа программных кодов, скриптов и тд, то рекомендуется использовать специализированные блокноты типа Notepad++, Sublime Text, Vim, Akelpad и тд

MSO Word предназначен для создания, просмотра, редактирования текстовых документов (не просто текстовых файлов) предназначеных в первую очередь для просмотра людьми. Потому очень много уделяется внимания форматированию текста, можно добавлять всякие рисунки, таблички и прочее и прочее
Можно редактировать и простые текстовые файлы, но это не удобно
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота