В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
Kamila281637
Kamila281637
13.06.2020 10:55 •  Информатика

Напишите программу, которая удаляет из строки все повторяющиеся символы. входные данные на вход программы подаётся строка, содержащая символы таблицы ascii. выходные данные программа должна вывести исходную строку, из которой удалены все повторяющиеся символы. примеры входные данные abc13a1b2z3c выходные данные abc132z входные данные qwasd123 выходные данные qwasd123 pascal abc 1.8

Показать ответ
Ответ:
zeleninalina20
zeleninalina20
05.10.2020 13:39

var str:string;i,n:integer;

begin

readln(str);

for i := 1 to length(str)-1 do

for n:=length(str) downto i+1 do

if str[n]=str[i]then delete(str,n,1);

writeln(str);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота