В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
chronicempty
chronicempty
22.07.2020 11:19 •  Информатика

Напишите программу, которая вводит натуральное число n и определяет его факториал, то есть произведение натуральных чисел от 1 до n : n ! = 1·2·{}· n . входные данные входная строка содержит одно натуральное число n . выходные данные программа должна вывести одно число – факториал введённого числа n .

Показать ответ
Ответ:
NazarKlakovych28
NazarKlakovych28
26.07.2020 08:23
Program pr;
var i,x,a:longint;
begin
readln(a);
x:=1;
for i:=2 to a do
x:=x*i;
writeln(x);
end.
0,0(0 оценок)
Ответ:
Huran
Huran
26.07.2020 08:23
Var
  i:integer;
  f,n:longint;
  fr:real;
begin
  Write('N='); Read(n);
  if n<=12 then begin
    f:=1;
    for i:=2 to n do f:=f*i;
    Writeln('F=',f)
  end
  else begin
    fr:=1;
    for i:=2 to n do fr:=fr*i;
    Writeln('F=',fr)
  end
end.

Тестовые решения:
N=12
F=479001600

N=13
F=6227020800

N=20
F=2.43290200817664E+18
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота