В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
pilel
pilel
25.01.2022 18:17 •  Информатика

Напишите программу, которая вводит последовательность целых чисел, заканчивающуюся нулём, и определяет, сколько из этих чисел удовлетворяет условию: сумма значений цифр десятичной записи числа равно 10.

Показать ответ
Ответ:
ZhannaMeer
ZhannaMeer
06.10.2020 03:36
Var
   A,S,k:longint;
Begin
k:=0;
Read(A);
While A<>0 do
   Begin
   S:=0;
   A:=Abs(A);
   While A > 0 do
      Begin
      S:=S+A mod 10;
      A:=A div 10;
      End;
   if S=10 then k:=k+1;
   Read(A);
   End;
WriteLn('Искомое количество: ',k);
End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота