В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
sayhun
sayhun
19.02.2022 00:12 •  Информатика

Напишите программу, которая вводит с клавиатуры числа до тех пор, пока не будет введено число 0. В конце работы программы на экран выводится минимальное и максимальное из введеных чисел( не считая 0) язык программирования C++​


Напишите программу, которая вводит с клавиатуры числа до тех пор, пока не будет введено число 0. В к

Показать ответ
Ответ:
shamil20042
shamil20042
14.02.2022 05:33

Что бы автоматически читать числа по одному в строке до определённого ввода, можно сделать цикл:

lst = []

x = int(input())

while x != 0:

   lst.append(x)

   x = int(input())

Такая конструкция позволит вам читать поток входных данных любой длины до момента ввода какого то числа.

Если вы хотите вводить числа просто через пробел, то можно использовать метод split() для строки считываемого входного потока, и полученный список строковых чисел уже приводить потом к нужному типу:

lst = input().split() # -> list of <str>

lst = list(map(int, lst)) #-> list of <int>

Ну, или в одну строку: lst = list(map(int, input().split()))

Так же вы можете считывать и автоматически приводить к нужному типу входные данные используя особую питоновую магию в виде генераторов списков:

lst = [int(i) for i in input().split()] # -> list of <int>

Функций, позволяющих считывать входной поток до определённого ввода, точнее, позволяющих организовать такой ввода в одну строку, я не встречал

Объяснение:

0,0(0 оценок)
Ответ:
LEZENR
LEZENR
25.08.2022 13:49

           int N, M; // Делимое, делитель

           int result = 0; // Частное

           N = Int32.Parse(Console.ReadLine());

           M = Int32.Parse(Console.ReadLine());

           while(N >= M)

           {

               N -= M;

               result++;

           }

           Console.WriteLine($"Частное: {result}, остаток: {N}");

           Console.ReadKey();

Объяснение:

Считываем вводимые переменные N и M для делимого и частного соответственно, приводим их к целочисленному типу, т.к. вводимые данные имеют строковый тип.

С цикла мы вычитаем из делимого делитель и прибавляем в переменную result единицу столько раз, сколько M помещается в N. Результатом такого цикличного вычитания и будет остаток.

Выводим на экран наши переменные с интерполяции строки и ожидаем нажатие клавиши, иначе консоль закроется.


Определить частное и остаток от деления двух целых чисел N и M, используя операцию вычитания. C#
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота