В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
Anastasiya2108
Anastasiya2108
24.03.2021 02:05 •  Информатика

Напишите программу, которая выбирает максимальное и минимальное из трёх введённых чисел. pascal

Показать ответ
Ответ:
vikaivanyk
vikaivanyk
02.10.2020 18:45
Var
a,b,c,max,min:integer;
Begin
Readln(a,b,c);
if (a>b) and (a>c) then max:=a;
if (b>a) and (b>c) then max:=b;
if (c>a) and (c>b) then max:=c;
if (a<b) and (a<c) then min:=a;
if (b<a) and (b<c) then min:=b;
if (c<a) and (c<b) then min:=c;
Writeln('Максимальное значение - ', max, 'Минимальное - ', min);
end.
0,0(0 оценок)
Ответ:
zabirovrobert
zabirovrobert
02.10.2020 18:45
PascalABC.Net

program MyProg;

var
  max_a, max1, min_a, min1, a, b, c: longint;

begin
  writeln('Введите три числа');
  readln(a, b, c);
  min1 := min(a, b);
  min_a := min(min1, c);
  max1 := max(a, b);
  max_a := max(max1, c);
  writeln('Максимальное число ', max_a);
  writeln('Минимальное число ', min_a);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота