В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
tevzi
tevzi
07.06.2020 10:23 •  Информатика

Напишите программу, которая запрашивает фамилии студентов и их почтовые адреса, записывает полученные данные в файл "номер_группы.txt" и
выводит список из файла на экран (Решение этой задачи может быть разным:
самое простое - организовать ввод и запись данных по одной строке, более
сложный вариант - организовать цикл из нескольких итераций, их количество
можно уточнять у пользователя: "Сколько строк данных Вы хотите ввести?"
или спрашивать после ввода одной строки: "Ввести еще данные?" и т.п. Здесь
можно решить любым , который Вам понятен на данном этапе
изучения языка).
сделать в питоне

Показать ответ
Ответ:
тоты2017
тоты2017
13.07.2021 19:00

1)

amount = 0

for i in range(1, 51):

   if (i % 2 == 0):

       amount += i

print(amount)

2)

from random import randint

lst = [randint(1, 100) for i in range(10)]

print(lst)

for i in range(len(lst)):

   lst[i] //= 2

print(lst)

Объяснение:

Парные числа - числа, которые делятся на 2 без остатка.

1)

amount = 0 // Переменная, хранящая сумму, равна нулю

for i in range(1, 51): // Берём элементы от 1 до 50 (первые 50 натуральных чисел)

   if (i % 2 == 0): // Если число делится на 2 без остатка

       amount += i // Сумма = сумма + i

print(amount) // Вывод ответа

2)

from random import randint // импорт функции randint() из библиотеки random

lst = [randint(1, 100) for i in range(10)] // Создание списка из рандомных чисел в диапазоне [1..100], состоящего из 10 элементов.

print(lst) // Выводим список

for i in range(len(lst)): // Берём индексы каждого элемента списка

   lst[i] //= 2 // Делим значение списка с индексом i на 2

print(lst) // Выводим список

0,0(0 оценок)
Ответ:
kate816
kate816
27.09.2021 19:02

Так, все значения одного реквизита в каком-либо отношении однородны. Под однородностью мы понимаем то, что значения одного реквизита характеризуют описываемый объект с какой-либо одной стороны например, по цвету, по назначению, по дате поступления и т.п. Это объясняется тем, что реквизит таблицы, по своему определению, задает одно горизонтальное отношение и тем самым обозначает один родовой признак объекта.

Объяснение:

Первый реквизит таблицы можно рассматривать как результат слияния последующих пяти, т.е. счет выступает в качестве идентификатора, объединяющего значения нескольких признаков в одно.

Первая и вторая таблицы связаны через общий реквизит — номер счета. Он позволяет в данных о движении денежных сумм не указывать подробные сведения о вкладчике, которые хранятся в первой таблице.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота