В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
Mihail568
Mihail568
28.04.2021 02:36 •  Информатика

Напишите программу на паскале. дан массив положительных и отрицательных чисел. вычислить сумму положительных и произведение отрицательных чисел. а[1..10]

Показать ответ
Ответ:
melnushyk099
melnushyk099
02.10.2020 14:05
Const m=10;
var
a:array[1..m] of integer;
i,sum,proz:integer;
begin
sum:=0;
proz:=1;
for i:=1 to m do
begin
read(a[i]);
if a[i]>0 then
sum:=sum+a[i]
else
ifa[i]<0 then
proz:=proz*a[i];
end;
writeln('Сумма положительных чисел= ',sum,' Произведение отрицательных чисел= ',proz);end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота