В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
Мaрсс
Мaрсс
24.11.2020 20:38 •  Информатика

Напишите программу на паскале, запрашивающую имя файла. в файле на первой строке количество злементов одномерного массива. ваша программа читает массив, создаёт файл с именем r.txt и записывает в него количество, а затем по одному на строке отрицательные элементы выданного вам файла, расположенные в порядке убывания

Показать ответ
Ответ:
Zzz111zzz15zz888zz
Zzz111zzz15zz888zz
29.08.2022 18:23
В неделе семь дней, поэтому решение выполняется на основе нахождения  остатка целочисленного деления от номера дня на 7. Такой остаток находится в пределах от 0 до 6, а для нашей нумерации нужны значения от 1 до 7, поэтому полученный остаток будем увеличивать на единицу. Если 1 января вторник, то есть день недели с номером 2, то первым понедельником будет 7 января, вторым 14 января и т.д. 1 января (k=1) при делении на 7 даст в остатке 1 и при сдвиге остатка на 1 (см. выше), получим 2 (вторник). 7 января даст остаток 0 и после сдвига получим 1 (понедельник), что и требовалось.

1. Современное короткое, эффективное, но требующее определенных знаний решение

PascalABC.NET 3.3.5, сборка 1659 от 09.04.2018
Внимание! Если программа не работает, обновите версию!

begin
  var d:='Понедельник Вторник Среда Четверг Пятница Суббота Воскресенье'.ToWords;
  Writeln(d[ReadInteger('Введите номер дня') mod 7])
end.

Примеры
Введите номер дня 215
Суббота

Введите номер дня 14
Понедельник

2. Более близкое к приведенному выше алгоритму решение

begin
  var n:=ReadInteger('Введите номер дня');
  n:=n mod 7+1;
  case n of
  0:Writeln('Воскресенье');
  1:Writeln('Понедельник');
  2:Writeln('Вторник');
  3:Writeln('Среда');
  4:Writeln('Четверг');
  5:Writeln('Пятница');
  6:Writeln('Суббота')
  end
end.

3. Типовое школьное решение

var
  n:integer;
begin
  Write('Введите номер дня');
  Read(n);
  n:=n mod 7+1;
  case n of
  0:Writeln('Воскресенье');
  1:Writeln('Понедельник');
  2:Writeln('Вторник');
  3:Writeln('Среда');
  4:Writeln('Четверг');
  5:Writeln('Пятница');
  6:Writeln('Суббота')
  end
end.
0,0(0 оценок)
Ответ:
сельджан2
сельджан2
22.06.2022 01:33

1) Построим таблицу истинности  

F = ¬B

B   F

0    1

1     0

0    1

1     0

Таблица не соответствует с той, которая в условии. Значит, этот вариант нам не подходит

2) F = B. Этот вариант нам подходит, потому что значение F и B совпадают. Но проверим и остальные варианты

3) Не подходит, т.к. по условию сказано, что переменные связаны

4) Посмотрим таблицу истинности F = A∧B

A   B   F

0   0   0

Мы уже видим, что наши таблицы не совпадают, поэтому дальше этот вариант можно и ре рассматривать.

ответ: 2

Подробнее - на -

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота