В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
89528849556keyz
89528849556keyz
24.05.2021 14:12 •  Информатика

Напишите программу на python, которая вычисляет средний рост учеников. Алгоритм должен в цикле пользователя ввести рост ученика. Цикл завершается, когда пользователь введет рост, равный нулю. Программа должна вывести средний рост учеников в классе.

Формат ввода
Вводятся целые числа одно за другим, на отдельных строках.

Формат вывода
Выводтся одно значение среднего роста

Показать ответ
Ответ:
карина2029
карина2029
12.10.2020 22:47

n=0

s=0

a=1

while a!=0:

   a=int(input())

   n+=1

   s+=a

print(s/(n-1))

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота