В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
Qwer948
Qwer948
29.01.2021 17:49 •  Информатика

Напишите программу на языке C++, которая находит сумму, произведение и среднее арифметическое трёх целых чисел, введённых с клавиатуры. Входные данные:
Три целых числа вводятся в одной строке через пробелы.

Выходные данные:
Программа должна вывести сумму, произведение и среднее арифметическое введенных чисел. Среднее арифметическое нужно вывести с точностью 3 знака после десятичной точки.

Примеры:
входные данные:
4 5 7
выходные данные:
4+5+7=16
4*5*7=140
(4+5+7)/3=5.333

Показать ответ
Ответ:
Alex200488005553535
Alex200488005553535
18.11.2020 12:58

Код программы:

#include <iostream>

using namespace std;

int main()

{

   int a, b ,c;

   cout<<"Введите 3 целых числа"<<endl;

   cin >>a>>b>>c;

   cout<<a<<"+"<<b<<"+"<<c<<"="<<a+b+c<<endl;

   cout<<a<<"*"<<b<<"*"<<c<<"="<<a*b*c<<endl;

   cout.precision(4);

   cout<<"("<<a<<"+"<<b<<"+"<<c<<")/3"<<"="<<(a+b+c)/3.<<endl;

   return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота