В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География

Напишите программу на языке pascal, которая с цикла for to считала s: =1-2+3-4+5-6+7-8+9-

Показать ответ
Ответ:
Челoвечeк
Челoвечeк
25.09.2020 06:34
Var n,i,s:integer;
begin
write('n = '); readln(n);
s:=0;
for i:=1 to n do 
 if i mod 2 =0 then s:=s-i else s:=s+i;
writeln('s = ',s);
end.

Пример:
n = 10
s = -5
0,0(0 оценок)
Ответ:
tratatya
tratatya
25.09.2020 06:34
Var n,s,i:integer;
begin
  write('введите n ');
  readln(n);
  for i:=1 to n do if i mod 2 <> 0 then s:=s+i else s:=s-i;
  writeln('s = ',s);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота