В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
maulee502owkszf
maulee502owkszf
21.12.2022 17:42 •  Информатика

Напишите программу, оптимизирующую диаметр и высоту тонкой жестяной банки объемом один литр, исходя из минимума затрат на металл, пошедший на ее изготовление Язык программирования: любой. Желательно Pascal или Python3

Показать ответ
Ответ:
rethd
rethd
07.08.2020 22:28
Язык Паскаль был создан Никлаусом Виртом в 1968—1969 годах после его участия в работе комитета разработки стандарта языка Алгол-68. Язык назван в честь французского математика, физика, литератора и философа Блеза Паскаля, который создал первую в мире механическую машину, складывающую два числа. Первая публикация Вирта о языке датирована 1970 годом, представляя язык, автор указывал в качестве цели его создания — построение небольшого и эффективного языка хорошему стилю программирования, использующемуструктурное программирование и структурированные данные.
0,0(0 оценок)
Ответ:
БиологКоля
БиологКоля
02.02.2022 08:02
Const n=10;
Var a:array[1..n] of integer;
i,k,j:integer;
Begin
Randomize;
    For i:=1 to n do  
       Begin 
         A[i]:=Random(10); 
         Write(a[i],' ');
     end;

          Writeln;

      For i:=1 to n do
           Begin
             If a[i] mod 3=0 then
             Write(a[i],' '); 
      end;
                   
for i:=1 to n-1 do
        for j:=1 to n-i do
            begin
                if (a[j] > a[j+1]) then
                    begin
                        k:= a[j];
                        a[j] := a[j+1];
                        a[j+1] := k;
                    end; 
                  end;  
                                       writeln;
                          for i:=1 to n do 
       write(a[i],' ');
        readln; 
     end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота