В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
Егор4002
Егор4002
07.02.2020 23:28 •  Информатика

Напишите программу, при которой можно подсчитать расходы на доставку мебели. исходные данные для расчета – номер этажа и информация о наличии и типе лифта (грузовой или обычный). c++

Показать ответ
Ответ:
hoivamvrot
hoivamvrot
08.10.2020 21:37
Надеюсь без ошибок. Цену за отдельные аспекты назначте сами:

#include stdlib.h
#include <iostream>
using namespace std;

int main() {
setlocale(LC_ALL, "Russian");

int floor;
char lift, type0;
double price_floor;
double price_elevator;
double price_type;
double total_price;
bool elevator;

cout << "Введите номер этажа: ";
cin >> floor;

if (floor == 1 || floor <= 3) price_floor=1;
if (floor <= 6 && floor > 3) price_floor=2;
if (floor <= 9 && floor > 6) price_floor=3;
else if price_floor=4;

cout << "Имеется ли в вашем помещении лифт? "; //ответ + или -
cin >> lift;
switch (lift) {
case '+':
price_elevator=1;
elevator=true;
break;
case '-':
price_elevator=2;
break;
}

if (elevator) {
cout << "Грузоподъемный? ";
cin >> type0;
switch (type0) {
case '+':
price_type=1
break;
case '-':
price_type=2;
break;
}
}
else if cout <<"\n";
cout <<"\n";
total_price=price_elevator + price_floor + price_type;
cout << "Конечная цена: " << total_price <<endl;
system ("pause");
return 0;
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота