В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
lour1
lour1
20.04.2023 09:39 •  Информатика

Напишите программу в Free Pascal 3.0.4

Шахматный слон ходит по диагонали. Даны две различные клетки шахматной доски, определите, может ли слон попасть с первой клетки на вторую одним ходом.
Входные данные
Программа получает на вход четыре числа от 1 до 8 каждое, задающие номер столбца и номер строки сначала для первой клетки, потом для второй клетки.
Выходные данные
Программа должна вывести YES, если из первой клетки ходом слона можно попасть во вторую или NO в противном случае.

Показать ответ
Ответ:
Алисика11
Алисика11
04.09.2022 16:22

Можно обойтись без массива и этим сэкономить память компьютера.

Можно также вывести такую матрицу (в виде песочных часов) любого размера. Для этого нужно только изменить значение n в строке

const n=5

 

Program Pentelemon;
uses crt;
const n=5;
var
 i,j:integer;
begin
  writeln('*** alphaues is thinking... ***');
  writeln('***          OK             ***');
  writeln();
  for i:=1 to n do
    begin
      for j:=1 to n do
        begin
          if ((j>=i) and (i+j<=n+1)) or ((j<=i) and (i+j>=n+1)) then
              write ('1 ')
            else
              write ('0 ');
        end;
      writeln();
    end;
end.

0,0(0 оценок)
Ответ:
kistina2
kistina2
07.04.2020 08:08

uses crt; {Подключение внешнего модуля}

var {Описание переменных}
a:array [1..100] of integer; 
n,i:integer;
begin
write('n='); {Вывод текста на экран}

read(n); {Чтение текста}
for i:=1 to 3 do
a[i]:=random(51); {Значение первых 3 элементов}
for i:=4 to n do
a[i]:=((a[i-1]+a[i-2]+a[i-3]) mod 10); {Значение остальных элементов}
writeln('Последовательность:'); {Вывод текста на экран}
for i:=1 to n do
write(a[i],' '); {Вывод последовательности на экран}
writeln; {Перевод указателя на следующую строку}
write('N-ный элемент: ',a[i]); {Вывод текста и элемента на экран}
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота