В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
ащя
ащя
17.12.2021 15:59 •  Информатика

Напишите программу в паскале для вычисления значений функции F(x)
1) F(x)=√x·cos²x
2) F(x)=1/2·sin·x/4+1

Показать ответ
Ответ:
Игнат282
Игнат282
10.03.2023 18:12
Тут есть два варианте решения, у Вас в задании написано что число Х и число А уже даны, то бишь с клавиатуры вводить их не надо. Тогда 1 вариант решения 1. и 2. задания:
1)
var x: integer;
begin
x:=5; // Поменяйте значение на нужное
writeln ('Квадрат числа ', x, ' = ',sqr(x));
end.
2)
var a,b: integer;
begin
a:=3; // Поменяйте значение на нужное
b:=a*2;
writeln ('Сумма A и B = ', a+b);
end.
2 вариант решения, все значения вводятся с клавиатуры:
1)
var x: integer;
begin
write ('Введите число Х: '); read(x);
writeln ('Квадрат числа ', x, ' = ',sqr(x));
end.
2)
var a,b: integer;
begin
write ('Введите число А: '); read (a);
b:=a*2;
writeln ('Сумма A и B = ', a+b);
end.
0,0(0 оценок)
Ответ:
dimakolobanov2
dimakolobanov2
15.03.2022 07:54
Program gulkakh;
const n=5;
var a:array[1..n,1..n] of integer;   
i,j,k,max,stroka:integer;
begin
writeln('Исходная матрица:');
for i:=1 to n do   
for j:=1 to n do    begin   
 a[i,j]:=random(20)-10;   
 write(a[i,j],' ');   
  if j=n then writeln; 
  end;   

 stroka:=1;
max:=a[1,1];

for i:=1 to n do
for j:=1 to n do begin
if max<a[i,j] then begin
max:=a[i,j];
stroka:=i;
end;
end;

k:=n;

for i:=stroka to n-1 do
for j:=1 to n do
a[i,j]:=a[i+1,j];
k:=k-1;
writeln('Без удаленной строки:');
for i:=1 to k do 
 for j:=1 to n do begin
  write(a[i,j],' '); 
if j=n then writeln; 
end;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота