В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
nicesasha2017
nicesasha2017
22.05.2021 14:35 •  Информатика

Напишите программу в python
последовательно запрашивающую ваши фамилия имя отчество и выводящую их одной строкой в последовательности: имя отчество фамилия​

Показать ответ
Ответ:
julv2
julv2
09.06.2020 15:31

1) program Array16;

var

i:integer; // счетчик в цикле

N:integer;

a: array [1..10] of integer;

begin

writeln('Введите N (N<10)');

readln(N); // ввод размера массива

for i:=1 to N do

begin

write('a[',i,']=');

readln(A[i]); // ручной ввод значений массива

end;

writeln('Результат');

for i:=1 to N do

begin

// вычисление и вывод элементов в указанном порядке

write(' ',a[(i div 2+1)*((i) mod 2)+ n*((i+1)mod 2)-((i div 2)-1)*((i+1) mod 2)]);

end;

end.

2) Var A:array[1..100] of integer;

i,n:byte;

Begin

write('Введите n<=100: ');readln(n);

For i:=1 to n do

Begin

A[i]:=random(31);

write(A[i]:3);

End;

writeln;

For i:=1 to n div 2 do

write(A[i]:3,A[n-i+1]:3);

if n mod 2 <>0 then write(A[n div 2+1]:3);

End.

0,0(0 оценок)
Ответ:
ganjaman007
ganjaman007
05.02.2021 21:46

number = int(input())

last_number = 0

even = 0

odd = 0

while (number > 0):

   last_number = number % 10

   if (last_number % 2 == 0):

       even += 1

   else:

       odd += 1

   number //= 10

print("Even = ", even, "Odd = ", odd)

Объяснение:

number = int(input())  // Объявление + ввод переменной

last_number = 0  // Переменная для хранения последней цифры числа

even = 0  // Количество четных

odd = 0  // Количество нечетных

while (number > 0):  // Пока число > 0

   last_number = number % 10  // Получаем последнюю цифру числа

   if (last_number % 2 == 0):  // Если цифра делится на 2 без остатка

       even += 1  // В переменную even делаем + 1

   else:  // Иначе

       odd += 1  // В переменную odd делаем + 1

   number //= 10  // Удаляем последнюю цифру числа

print("Even = ", even, "Odd = ", odd) // Вывод

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота