В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
killskorpion19
killskorpion19
02.12.2022 09:56 •  Информатика

Напишите программу (в тетради) рассчитывающую количество цветов (Y), подаренных на 8 марта девочкам (X) и остаток. Используйте операторы div и mod. X,Y вводите с клавиатуры.

Показать ответ
Ответ:
dv1ne
dv1ne
09.04.2021 17:21

program tsveti;

var x,y,z,w:integer;

begin

   write('Введите количество девочек: '); readln(x);

   write('Введите количество цветов: '); readln(y);

   if (y div x) mod 2 = 0 then begin // здесь мы проверяем, не получается ли чётное количество цветков, и если получается чётное, то вычитаем остаток и количество девочек, чтобы добиться нечётного количества

       w := y mod x + x;

       z := (y - w) div x;

   end

   else begin

       w := y mod x;

       z := y div x;

   end;

   writeln('Девочкам подарили по ', z, ' шт. цветков.');

   writeln('Осталось ', w, ' шт. цветков.');

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота