В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
rita239
rita239
09.05.2020 09:00 •  Информатика

Напишите программу вычисления выражения: s=1! +2! +3! ++n! здесь n! - факториал числа n. n! =1×2××(n-1)× n.используйте функцию вычисления факториала..​

Показать ответ
Ответ:
Хорошоучусь
Хорошоучусь
10.10.2020 01:12

var

   n : integer;

   S : decimal;

   

function fac(n : integer) : decimal;

begin

   result := 1;

   for var i := 1 to n do result := result * i;

end;


begin

   write('введите n = ');

   readln(n);

   for var i := 1 to n do S := S+fac(i);

   writeln('S=', S);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота