Напишите шуточную программу-тест, в которой пользователь задает свой вопрос, а программа выдает ответ случайным образом из списка «универсальных ответов», к примеру 'ты сам не знаешь ? '
Var n1,n2,n3,n4,n5:integer; begin Readln(n1,n2,n3,n4,n5); If (n1>n2) and (n1>n3) and (n1>n4) and (n1>n5) then writeln('Максимальное число: ',n1) else If (n2>n1) and (n2>n3) and (n2>n4) and (n2>n5) then writeln('Максимальное число: ',n2) else If (n3>n1) and (n3>n2) and (n3>n4) and (n3>n5) then writeln('Максимальное число: ',n3) else If (n4>n1) and (n4>n3) and (n4>n2) and (n4>n5) then writeln('Максимальное число: ',n4) else writeln('Максимальное число: ',n5); end.
Запишем таблицу распределения мест по купе: Купе Места 1 1-4,53,54 2 5-8,51,52 3 9-12,49,50 4 13-16,47,48 5 17-20,45,46 6 21-24,43,44 7 25-28,41,42 8 29-32,39,40 9 33-36,37,38 Установим связь номера места с номером купе. Предлагается следующий (конечно же, не единственный) вариант:
Здесь знаком ÷ обозначена операция целочисленного деления.
Теперь можно написать программу. Язык программирования в задании не указан, поэтому выбран язык свободно распространяемой для целей обучения системы программирования PascalABC.Net
var n:integer; begin Write('Укажите номер места: '); Read(n); Write('Место располагается в купе №'); if n<=36 then Write((n-1) div 4 + 1) else Write((54-n) div 2 + 1) end.
Тестовое решение: Укажите номер места: 18 Место располагается в купе №5
n1,n2,n3,n4,n5:integer;
begin
Readln(n1,n2,n3,n4,n5);
If (n1>n2) and (n1>n3) and (n1>n4) and (n1>n5) then
writeln('Максимальное число: ',n1)
else If (n2>n1) and (n2>n3) and (n2>n4) and (n2>n5) then
writeln('Максимальное число: ',n2)
else If (n3>n1) and (n3>n2) and (n3>n4) and (n3>n5) then
writeln('Максимальное число: ',n3)
else If (n4>n1) and (n4>n3) and (n4>n2) and (n4>n5) then
writeln('Максимальное число: ',n4)
else
writeln('Максимальное число: ',n5);
end.
Купе Места
1 1-4,53,54
2 5-8,51,52
3 9-12,49,50
4 13-16,47,48
5 17-20,45,46
6 21-24,43,44
7 25-28,41,42
8 29-32,39,40
9 33-36,37,38
Установим связь номера места с номером купе. Предлагается следующий (конечно же, не единственный) вариант:
Здесь знаком ÷ обозначена операция целочисленного деления.
Теперь можно написать программу. Язык программирования в задании не указан, поэтому выбран язык свободно распространяемой для целей обучения системы программирования PascalABC.Net
var
n:integer;
begin
Write('Укажите номер места: '); Read(n);
Write('Место располагается в купе №');
if n<=36 then Write((n-1) div 4 + 1)
else Write((54-n) div 2 + 1)
end.
Тестовое решение:
Укажите номер места: 18
Место располагается в купе №5