В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
Маркус337
Маркус337
02.03.2023 04:14 •  Информатика

Нарисуйте данный рисунок на turtle Python


Нарисуйте данный рисунок на turtle Python

Показать ответ
Ответ:
Yulia14929
Yulia14929
16.09.2022 04:16

#include <iostream>

using namespace std;

int main() {

setlocale(LC_ALL, "Russian");

   int n, a, b, c, d, e, f, k=0;

   cin >> n;

   a=n%10;

   b=n%100/10;

   c=n%1000/100;

   d=n/1000;

   e=n-d*1000-b*10+d*10+b*1000;

   cout<<e<<endl;

   if (a%2==0)++k; if (b%2==0)++k; if (c%2==0)++k; if (d%2==0)++k;

   f=a; if (b<f) f=b; if (c<f) f=c; if (d<f) f=d;

   if (b>a) a=b; if (c>a) a=c; if (d>a) a=d;

   cout<<"Наименьшая цифра числа "<<f<<endl<<"Наибольшая цифра числа "<<a<<endl;

   if (n%2==0)cout<<"Число делится на 2"<<endl;

   else cout<<"Число не делится на 2"<<endl;

   if (n%7==0)cout<<"Число делится на 7"<<endl;

   else cout<<"Число не делится на 7"<<endl;

   if (n%123==0)cout<<"Число делится на 123"<<endl;

   else cout<<"Число не делится на 123"<<endl;

   cout<<"Число четных цифр в числе равно "<<k<<endl;

   return 0;

}

0,0(0 оценок)
Ответ:
Chehows
Chehows
27.11.2020 10:17

#include <iostream>
using std::cout;
using std::endl;
#include <cstdlib>
using std::rand;
using std::srand;
#include <ctime>
using std::time;

int main()
{
    int a[10];

    srand(time(0));

    for(int i = 0; i < 10; i++)
    {
        a[i] = rand() % 201 - 100;

        cout << a[i] << ' ';
    }
    cout << endl;

    int temp;
    for(int i = 0; i < 5; i++)
    {
        temp = a[i];
        a[i] = a[i + 5];
        a[i + 5] = temp;
    }

    for(int i = 0; i < 10; i++)
    {
        cout << a[i] << ' ';
    }
    cout << endl;

    return 0;
}


Написать программу, которая генерирует и выводит на экран массив из 10 случайных чисел в диапазоне о
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота