В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
Женя11134
Женя11134
24.11.2022 14:57 •  Информатика

Найдите с блок-схемы значение a,b и c. написать программу (на вычисление не обращайте внимания).

Показать ответ
Ответ:

Исполнители бывают двух типов: формальные (выполняют действия не понимая смысла работы) и неформальные (понимают то, что делают и могут изменить действия в алгоритме)

а) симфонический оркестр - неформальный исполнитель - могут вносить свои чуства в исполнение, понимают то, что делают музыканты.

б) ученик сам решает - неформальный испонитель

в) ученик списывает - формальный исполнитель

г) фармацевт - формальный (точное исполнение рецепта иначе может быть другой результат от лечения)

д) врач - неформальный исполнитель, тк зная возможные причины рассматривает разыне варианты, учитывая особенности данного человека

е) автомат - формальный исполнитель, вообще не понимает своих действий, выполняет заданную программу

ж) компьютер - формальный исполнитель - выполняет программу, созданную программистами.

0,0(0 оценок)
Ответ:
xachik1998
xachik1998
13.09.2021 18:32
program Project1;  uses crt; const   //Разделители слов.   D = ['.', ',', ':', ';', '!', '?', '-', ' ', #9, #10, #13]; var   S : String;   i, Cnt, Len : Integer; begin   repeat     Writeln('Задайте строку:');     Readln(S);       Len := Length(S);     Cnt := 0;     for i := 1 to Len do begin       //Пропускаем разделители.       if S[i] in D then Continue;       //Отслеживаем начало слова.       if (i = 1) or (S[i - 1] in D) then begin         if S[i] in ['a', 'A'] then Cnt := Cnt + 1;       end;     end;     Writeln('В заданной строке найдено ', Cnt, ' слов,');     Readln(S);   until S <> ''; end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота