В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
HICKOinc
HICKOinc
11.03.2021 10:33 •  Информатика

найти ошибку в решении. Составить программу вычисления следующей функции на языке программирования Turbo Pascal

Показать ответ
Ответ:
svetlans2
svetlans2
20.05.2023 06:31
Вопрос № 1 
свойства алгоритма:
Имеет законченное количество шагов
Предназначен для решения конкретной задачи

Состоит из дискретных шагов-инструкций
Может быть использован для решения целого класса задач
Шаги - инструкции должны быть четкими, понятными исполнителю
Вопрос № 2 
По форме записи алгоритмы бывают
текстовые

графические

Вопрос № 3 
Выбери правильные высказывания:

Текстовое описание и блок-схема - это две разные модели описания решения задачи.
Алгоритм с ветвлением содержит блок, в котором один вход для данных и два выхода: "Да" и "Нет".
Линейный алгоритм состоит из последовательности шагов, которые исполняются один за другим.
Вопрос № 4 
По последовательности исполнения команд различают алгоритмы

линейные
с ветвлением
Вопрос № 5 
Выбери команды (перечисли их номера), которые могут входить в систему команд исполнителя "КОМПЬЮТЕР":

Прыгнуть

Напечатать
0,0(0 оценок)
Ответ:
Болыс111
Болыс111
05.12.2020 00:36
1.
N=int(input())
s=2
flag=False
for i in range(N):
      if N=s:
           flag=True
           break
      else:
           s*=2
if flag:
    print('Yes')
else:
    print('No')

2.
n=int(input())
def MinDivisor(n):
     nod=-1
     for i in range(n-1):
          if n%i=0:
              return i
              break

if MinDivision(n)==-1:
    print(n,' число является простым.')
else:
    print(MinDivision(n))

3.
A=int(input())
x=x1=1
s=0
while x1<A+2:
   b=x
   x=x1
   x1+=b
   s+=1
if x1==A:
    print(s)
else:
    print(-1)

4. 
a=[]
while 1:
   s=int(input())
   if s==0:
       break
   a.append(s)
a.sort()
print(a[-2])
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота