Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
Показать больше
Показать меньше
Kartrider
24.02.2021 23:41 •
Информатика
Найти произведение всех элементов массива вещественных чисел, меньших заданного числа. размерность массива –10. заполнение массива осуществить случайными числами от 50 до 100.
Показать ответ
Ответ:
Сос1111111
08.10.2020 21:12
Begin
var n := ReadlnReal('n =');
var arr := ArrRandomReal(10, 50, 100).Println;
arr.Where(t -> t < n).Aggregate(1.0, (p,x) -> p * x).Println;
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
dragons55u
23.07.2022 06:18
Дана блок-схема. Какое значение будет иметь z на выходе, если x=42? (промежуточные вычисление не округляйте; ответ округли до десятых)...
Buboschka
08.03.2022 04:34
Программист ошибся в записи оператора присваивания на языке Паскаль: x:=a*3+sqrt9. Какая ошибка допущена?...
masha71301291
31.05.2022 13:53
Какой это граф? ответьте...
Alla221
10.08.2021 18:23
На питоне Используя файл ассортимент.txt, содержащий сведения об игрушках, найти. Для каждой записи указать название игрушки (кукла, кубики, конструктор и т.д.), её стоимость...
любовь270
15.10.2022 17:58
Определите, что выведет на экран программа при вызове F(9). procedure F(n: integer); begin if n 3 then begin F(n – 4); F(n div 2); end; write(n); end;...
muratowaasya
14.01.2023 05:00
Вставьте пропущенное слово всегда следует продумывать решение ответы план схема описание макет таблица...
Petrasir
08.06.2023 23:06
Сколько бит информации несет сообщение о том, что поезд прибывает на один из 8 путей, если информация рассматривается как снятая неопределенность? с подробным решением...
Roblox777
08.06.2023 23:06
Составьте программу, которая формирует массив из пятнадцати случайных целых чисел от -20 до 20 и отрицательные числа возводит в квадрат, а из неотрицательных извлекает квадратный...
daniilznanija0
05.06.2020 14:11
Расставьте виды памяти в порядке увеличения быстродействия. регистры, дисковая память, кэш память, оперативная, компьютерная сеть...
daniilgurnyy
11.09.2021 15:33
Информатика 9 класс. составьте программу, которая заполняет массив а[1..10] случайными целыми числами в диапазоне от 1 до 10 и находит количество элементов, которые больше своего...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
var n := ReadlnReal('n =');
var arr := ArrRandomReal(10, 50, 100).Println;
arr.Where(t -> t < n).Aggregate(1.0, (p,x) -> p * x).Println;
end.