В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География

Необходимо написать программу, которая получает на вход натуральные положительные числа. Ввод чисел прекращается при вводе любого отрицательного числа (точка остановки). Необходимо сделать так, чтобы программа выводила на экран сумму введенных чисел, но только тех, которые оканчиваются на 3 и делятся на 7. (См. материал Python – урок №4, раздел «Подсчет количества элементов, удовлетворяющих условию», там есть похожий пример). .​

Показать ответ
Ответ:
кйф5
кйф5
20.10.2022 15:05

1. Какова последовательность шагов для загрузки изображения в Paint.NET?

Команды работы с документами выполняются из меню «Файл». Команда «Открыть» позволяет выбрать и открыть уже нужный файл изображения.

2. Как изменить размер открытого изображения?

В графическом редакторе Paint.NET можно сделать как с изменением масштаба основной части изображения и его пропорций, так и с их сохранением.  

Изменения размера изображения с команды «Изменить размер»:

Открыть изображение в Paint.NET и открыть окно изменения размера (Изображение — Изменить размер…). В этом окне есть возможность установки качества изменения размера, задания размера в процентном выражении, а также указания абсолютного размера и разрешения изображения. Поэтому нам нужно просто ввести в поле «Ширина» или «Высота» нужное значение и нажать на кнопку «ОК».

Уменьшение размера изображения с команды «Размер полотна»:

Для вызова окна изменения размера полотна используется команда (Изображение — Размер полотна…). С инструмента закрепления можно указать ту область изображения, которая будет считаться главной при изменении размера полотна. Как правило такой областью является та, в которой размещен основной объект изображения. Нужно просто ввести в поле нужное значение и нажать на кнопку «ОК».  

3. Как сделать изображение вертикальным или горизонтальным?

Зайти в меню "Изображение" в Paint.NET и выбрать нужное «перевернуть горизонтально» или «перевернуть вертикально».  

4. Какие еще действия можно выполнять с открытыми изображениями?

Ввести текст, добавить Эффекты, изменить размеры изображения, седлать горизонтальным или вертикальным, сохранить файл в разных форматах, напечатать.  

Объяснение:

0,0(0 оценок)
Ответ:
MrFoksSuper
MrFoksSuper
27.01.2023 07:28
Program Number;
var  x: integer; { введенное число }  n: byte := 0; { количество цифр в числе }  i, j: byte; { счетчики }  xi: array[1..5] of integer;{массив цифр, из которых состоит число}
begin  { Ввод исходного числа }  readln(x);  writeln;   x := abs(x); // рассматриваем модуль числа  { Разбиение числа на цифры }  while (x > 0) do  begin    n := n + 1; // увеличиваем количество цифр    xi[n] := x mod 10; // вычисляем цифру (остаток от деления на 10)    if xi[n] = 8 then // если встретилась 8,    begin      writeln('да'); // то число "бесконечное"      readln;      exit;          // выход из программы    end;    x := x div 10; // изменяем число (целое от деления на 10)  end;  { Поиск цифр, встречающихся больше одного раза}  for i := 1 to n - 1 do    for j := i + 1 to n do      if xi[i] = xi[j] then // если числа      begin        writeln('да'); // то число "бесконечное"        readln;        exit;  // выход из программы       end;  { Число не явлется "бесконечным" }  writeln('нет');end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота