В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
Maksgeem
Maksgeem
19.08.2020 13:24 •  Информатика

Неверно сконструировано форматное выражение...
Задание: Составьте программу заполнения массива из 100 чисел случайными значениями из диапазона от -20 до 20. Подсчитайте в этом массиве количество положительных и количество отрицательных значений. ХЕЛП

Показать ответ
Ответ:
данил2048
данил2048
17.03.2023 09:50

#include <iostream>

#include <math.h>

#include <stdio.h>

using namespace std;

int main() {

double a,b,c,d,x1,x2;

cout<<"a, b, c:"<<endl;

cin>>a>>b>>c;

d=b*b-4*a*c;

if(d>0) {

 x1=(-b+sqrt(d))/(2*a);

 x2=(-b-sqrt(d))/(2*a);

 cout<<"double root:"<<endl;

 cout<<x1<<" "<<x2;

}

else

 if(d<=0) cout<<"no roots"<<endl;

 else if(d==0) {

  x1=-b/2*a;

  cout<<"one root:"<<endl<<x1;

 }

getchar();

return 0;

}

Исправил тебе код.

Очень, ОЧЕНЬ много ошибок.

После инклюдов ; не ставится.

Зачем тебе программа для решения квадратных уравнений если она не может работать с дробями. Надо использовать для переменных тип double.

Функция квадратного корня пишется sqrt, а не sgrt.

В C и C++ переменные d и D - разные. Регистр имеет очень большое значение.

cin>>double root>>; - что ты вообще хочешь этим сделать. Тебе нужно вывести корни, а ты что-то непонятное делаешь.

cin>>one root>>; - аналогично

cin>>notroot>>; - аналогично

cout<<"not root:"<<endl; - грамматическая ошибка

Присвоение в C и C++ это =, а не :=.

По поводу if-else - сам почитай.

{}{}{}{}{} - для каждой { должна быть }

Самая первая проверка d должна выглядеть d>0, а не d>=0; будет ответ неверным.

Проверка на равенство в C/C++ выглядит (a==b)

И много-много другого

0,0(0 оценок)
Ответ:
docogov
docogov
05.08.2021 19:56
Вот программа : program xxx; 
<p>program xxx;</p><p>&nbsp;&nbsp; var i, k, d, e, s : integer;</p><p>begin</p><p>&nbsp; k:=0;</p><p>&nbsp;for i:= 10 to 99 do</p><p>&nbsp;&nbsp; begin</p><p>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; d:= i div 10;</p><p>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; e:= i mod 10;</p><p>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; s:=d + e;</p><p>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; if i mod s = 0 then k:=k+1</p><p>&nbsp;&nbsp; end;</p><p>&nbsp;&nbsp; write ('кол-во чисел которые делятся на сумму своих цифр=', k);</p><p>&nbsp;&nbsp; readln</p><p>end.</p>
Найдите количество двузначных чисел, которые делятся на сумму своих цифр.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота