В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
KitKat321456
KitKat321456
01.06.2022 07:34 •  Информатика

нужна На вход программы подаётся запись квадратного уравнения. Гарантируется, что коэффициент
уравнения при x 2 не равен нулю, все коэффициенты определены и корни вещественные.
Напишите программу, которая находит корни уравнения.
Входные данные
Входная строка содержит запись квадратного уравнения, в которой используются специальные
обозначения: x 2 обозначается как «a», x обозначается как «b». Например, уравнение 2 x 2 - 4 x -
6 запишется в виде строки 2a-4b-6 . Коэффициенты уравнения могут быть вещественными.
Выходные данные
Программа должна вывести два вещественных корня квадратного уравнения (в порядке
возрастания) в одной строке, разделив их пробелом. Значения должны быть выведены с тремя
знаками в дробной части.
Примеры
входные данные
2a-4b-6
выходные данные
-1.000 3.000

Показать ответ
Ответ:
kivonen3p08qoq
kivonen3p08qoq
19.09.2020 13:27
Вопрос с подвохом, пропускная меряется не от возможной передачи на стороне провайдера или пользователя, а от версии протокола 2СH (2 цэ-аш). Рассмотрим 2 последние версии. Протокол 2015 года поддерживал пропускную вплоть до 20 MB/WEBM. Стандарт нового протокола поразили многих экспертов, скорость была снижена вдвое. Но сделано это было в связи с отказом многих производителей сетевого оборудования устанавливать расширяющие микросхемы PassCODE для поддержки тех самых 20 MB/WEBM. Может в будущем, с большим распространением PassCODE пропускную поднимут, но пока приходится с этими ограничениями смирится и перекодировать WEBM что несомненно, приведет к ухудшению их качества. 
0,0(0 оценок)
Ответ:
nyarokhno
nyarokhno
06.05.2022 19:01
//1. Переборный алгоритм Евклида (цикл repeat)

var a, b, с: integer; 

begin

  write('Введите два числа: ');

  readln(a, b);

  if a < b then с := a + 1 else с := b + 1;

repeat с := с - 1

  until (a mod с = 0) and (b mod с = 0);

  write('NOD = ', с)

end.

 

//2. Алгоритм с вычитанием (цикл while)

var  a, b: integer;

begin

  write('a = ');

  readln(a);

  write('b = ');

  readln(b);

  while a <> b do

    if a > b then

      a := a - b

    else

      b := b - a;

  writeln('NOD = ', a);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота